[Check_mk (english)] Problem with cisco_ace_rserver script

Caines, Max Max.Caines at wlv.ac.uk
Mon Aug 3 00:23:14 CEST 2015


Hi

I noticed today that this script has been added to the repository, and I have an ACE module, so I installed it. I ran an inventory check against the ACE, but the check didn't get added. I tried running that specific check from the CLI with debugging on, and got this output:

OMD[uow]:~/share/check_mk/checks$ cmk --debug -v --checks=cisco_ace_rserver -I mx-ace
Discovering services on mx-ace:
mx-ace:
   Running snmpbulkwalk -v2c -c 'xxxxxx' -m '' -M '' -Cc -OQ -OU -On -Ot 134.220.6.3 .1.3.6.1.4.1.9.9.470.1.1.1.1.1
   Running snmpbulkwalk -v2c -c 'xxxxxx' -m '' -M '' -Cc -OQ -OU -On -Ot 134.220.6.3 .1.3.6.1.4.1.9.9.470.1.1.1.1.4
   Running snmpbulkwalk -v2c -c 'xxxxxx' -m '' -M '' -Cc -OQ -OU -On -Ot 134.220.6.3 .1.3.6.1.4.1.9.9.470.1.1.1.1.5
   Running snmpbulkwalk -v2c -c 'xxxxxx' -m '' -M '' -Cc -OQ -OU -On -Ot 134.220.6.3 .1.3.6.1.4.1.9.9.470.1.1.1.1.12
   Running snmpbulkwalk -v2c -c 'xxxxxx' -m '' -M '' -Cc -OQ -OU -On -Ot 134.220.6.3 .1.3.6.1.4.1.9.9.470.1.1.1.1.13
   Running snmpbulkwalk -v2c -c 'xxxxxx' -m '' -M '' -Cc -OQ -OU -On -Ot 134.220.6.3 .1.3.6.1.4.1.9.9.470.1.1.1.1.19
Exception in discovery function of check type cisco_ace_rserver
Traceback (most recent call last):
  File "/omd/sites/uow/share/check_mk/modules/check_mk.py", line 5731, in <module>
    do_discovery(hostnames, check_types, seen_I == 1)
  File "/omd/sites/uow/share/check_mk/modules/discovery.py", line 68, in do_discovery
    do_discovery_for(hostname, check_types, only_new, use_caches)
  File "/omd/sites/uow/share/check_mk/modules/discovery.py", line 81, in do_discovery_for
    new_items = discover_services(hostname, check_types, use_caches, do_snmp_scan)
  File "/omd/sites/uow/share/check_mk/modules/discovery.py", line 285, in discover_services
    for item, paramstring in discover_check_type(hostname, ipaddress, check_type, use_caches):
  File "/omd/sites/uow/share/check_mk/modules/discovery.py", line 406, in discover_check_type
    discovered_items = list(discovered_items)
  File "/omd/sites/uow/share/check_mk/checks/cisco_ace_rserver", line 35, in inventory_cisco_ace_rserver
    item = socket.inet_ntoa(ip)
socket.error: packed IP wrong length for inet_ntoa

So then I checked the output from the SNMP walk. There are about 20 entries, and these are just the first few:

snmpbulkwalk -v2c -c 'xxxxxx' -m '' -M '' -Cc -OQ -OU -On -Ot 134.220.6.3 .1.3.6.1.4.1.9.9.470.1.1.1.1.4
.1.3.6.1.4.1.9.9.470.1.1.1.1.4.9.5.67.65.83.48.49 = "86 DC 02 80 "
.1.3.6.1.4.1.9.9.470.1.1.1.1.4.9.5.67.65.83.48.50 = "86 DC 02 81 "
.1.3.6.1.4.1.9.9.470.1.1.1.1.4.9.5.67.65.83.48.51 = "86 DC 02 C1 "

Putting the first of those through a hex to IP converter, I get 134.220.2.128, which is a valid IP address of one of our servers. So what is inet_ntoa objecting to? Any ideas?

Thanks

Max Caines
University of Wolverhampton




-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mathias-kettner.de/pipermail/checkmk-en/attachments/20150802/c6dda0df/attachment.html>


More information about the checkmk-en mailing list