[Check_mk (english)] Cisco Temperature Warning False Positive?

Andreas Döhler andreas.doehler at gmail.com
Mon Feb 9 09:31:01 CET 2015


What version of CMK do you use? At 1.2.4p5 there is no precision counter
read inside the cisco_temp_sensor check.
At the 1.2.6bx there is already the addition for this counter. In the
result you get automatic division or multiplication by 10 for your sensor
values.
Inside the 1.2.4 check there are some code-lines what divide the value by
10 if there 4 values for the levels present. (I don't know why :) )
Line 148-151

This looks like your problem if you use the cisco_temp_check.

Best regards
Andreas


Patrick Flaherty <pflaherty at wsi.com> schrieb am Thu Feb 05 2015 at 22:17:29:

On Wed, Feb 4, 2015 at 7:15 PM, Jesse Shumaker <jshumaker at crexendo.com>
> wrote:
>
>> I have logged in to the ASR 1002 where this warning is occurring:
>> http://cl.ly/image/0L051A2V0u3Z and I can't see where this issue lies.
>> Everything in my environment checks within the router looks normal. Is
>> there is an issue with how this cisco check reports on this particular
>> check?
>>
>> https://mathias-kettner.de/checkmk_check_cisco_temp.html
>
>
> I noticed the same thing, it's off by a multiple of 10, and doesn't
> reflect what's in show env. Well it may be more that show env doesn't have
> the level for the "hot spot" temp, where as the mib provides it.
>  _______________________________________________
> checkmk-en mailing list
> checkmk-en at lists.mathias-kettner.de
> http://lists.mathias-kettner.de/mailman/listinfo/checkmk-en
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mathias-kettner.de/pipermail/checkmk-en/attachments/20150209/4b830d6f/attachment-0001.html>


More information about the checkmk-en mailing list