[Check_mk (english)] Getting an Allnet ALL4500 to work with CMK

Andreas Döhler andreas.doehler at gmail.com
Tue Feb 17 15:00:17 CET 2015


Inside the actual GIT is an very new Allnet check with special agent
available.
It would be good if you have a look at this and the actual check to know
what is missing in your setup.

Special Agent:
http://git.mathias-kettner.de/git/?p=check_mk.git;a=blob;f=agents/special/agent_allnet_ip_sensoric
CMK Check for this agent:
http://git.mathias-kettner.de/git/?p=check_mk.git;a=blob;f=checks/allnet_ip_sensoric

Best regards
Andreas

Marcel Schulte <schulte.marcel at gmail.com> schrieb am Tue Feb 17 2015 at
14:54:45:

> I ment "checktype", not "checkmate" ;-)
>
> Marcel Schulte <schulte.marcel at gmail.com> schrieb am Di., 17. Feb. 2015
> 14:49:
>
> Looks normal - but you have to develop your checkmate "sensoren" because
>> cmk does not know what to do with the received data:
>> http://mathias-kettner.com/checkmk_devel_agentbased.html
>>
>> Marcel
>>
>> Jonas Neumann <cmk at tschanness.de> schrieb am Di., 17. Feb. 2015 13:37:
>>
>> Hi Marcel,
>>> thanks for the fast answer :)
>>> CMK only shows the Ping output nothing else. If I open the service Tab
>>> it shows nothing.
>>> The Host is configured a normal Host in WATO with the datasource
>>> Program as followed:
>>> ssh root at 10.35.12.11 /root/check_mk_agent.sensormeter
>>>
>>> The outpuf of cmk -d:
>>>
>>> OMD[rcs_monitor]:~$ cmk -d mlakcpkp01
>>> <<<check_mk>>>
>>> Version: 1.2.4
>>> AgentOS: linux-embedded
>>> <<<sensoren>>>
>>> P Sensor 1: Temperatur 22.30
>>> P Sensor 2: Temperatur 25.71
>>> P Sensor 3: Temperatur 20.40
>>>
>>> Thank you for your Time!
>>>
>>> Jonas
>>>
>>> On Tue, Feb 17, 2015 at 1:29 PM, Marcel Schulte
>>> <schulte.marcel at gmail.com> wrote:
>>> > Hi Jonas,
>>> >
>>> > What exactly does not work when you use your own "agent"?
>>> > How do you configure the host in CMK?
>>> > Does "cmk -d HOSTNAME" output anything? Could you post the output?
>>> >
>>> > Regards,
>>> > Marcel
>>> >
>>> > Jonas Neumann <cmk at tschanness.de> schrieb am Tue Feb 17 2015 at
>>> 13:15:08:
>>> >>
>>> >> Hello,
>>> >> I have an Allnet ALL4500 Applicane wich does not deliver its values
>>> >> via SNMP. It is possible to Access the device via SSH but i was not
>>> >> able to get the linux agent to work. I tried to programm a small
>>> >> "Agent", wich only outputs the Sensor values:
>>> >>
>>> >> <<<check_mk>>>
>>> >> Version: 1.2.4
>>> >> AgentOS: linux-embedded
>>> >> <<<sensoren>>>
>>> >> P Sensor 1: Temperatur 22.55
>>> >> P Sensor 2: Temperatur 25.80
>>> >> P Sensor 3: Temperatur 19.64
>>> >>
>>> >> This does not work either :). I thought about using NRPE but it is
>>> >> superseeded by MRPE (wich requires the agent, right?). So I'm stuck
>>> >> and don't know how to proceed. Any advice on how to get this working
>>> >> as easy as possible? Thank you in advance!
>>> >>
>>> >> Jonas
>>> >> _______________________________________________
>>> >> checkmk-en mailing list
>>> >> checkmk-en at lists.mathias-kettner.de
>>> >> http://lists.mathias-kettner.de/mailman/listinfo/checkmk-en
>>>
>> _______________________________________________
> checkmk-en mailing list
> checkmk-en at lists.mathias-kettner.de
> http://lists.mathias-kettner.de/mailman/listinfo/checkmk-en
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mathias-kettner.de/pipermail/checkmk-en/attachments/20150217/e19af10a/attachment-0001.html>


More information about the checkmk-en mailing list