[Check_mk (english)] WATO parameters for custom plugin

Marcel Schulte schulte.marcel at gmail.com
Fri Oct 9 10:01:14 CEST 2015


Thanks for the information. Settings changed between 1.2.4 and 1.2.6 I
think - that was the point in question.

I'll check your code...

Marcel

Paul Bongers <Paul.Bongers at osudio.com> schrieb am Fr., 9. Okt. 2015 um
09:57 Uhr:

> Hi Marcel,
>
> I'm currently running 1.2.6p10.cre.
>
> Regards,
>
> Paul
>
>
> On 09/10/15 09:50, Marcel Schulte wrote:
>
> Hi Paul,
>
> the default setting depend on your used CMK version - which is it?
>
> Regards,
> Marcel
>
> Paul Bongers <check-mk at paul-bongers.nl> schrieb am Do., 8. Okt. 2015 um
> 22:21 Uhr:
>
>> Hi Marcel,
>>
>> Attached you'll find both the check script and the WATO plugin I've
>> written.
>>
>> I might add that I'm a little fuzzy on where I should pass the default
>> parameters, either in the inventory function or in the check_info (see
>> commented lines at the end of the check script).
>>
>> Thanks in advance.
>>
>> Regards,
>>
>> Paul
>>
>> On 8-10-2015 17:04, Marcel Schulte wrote:
>> > Hi Paul,
>> >
>> > Could you provide the check itself as well as the file providing the
>> > WATO rule section for your script?
>> >
>> > Regards,
>> > Marcel
>> >
>> >
>> > Paul Bongers <check-mk at paul-bongers.nl
>> > <mailto:check-mk at paul-bongers.nl>> schrieb am Do., 8. Okt. 2015 16:55:
>> >
>> >     I haven't yet found any way to implement this correctly.
>> >
>> >     Can someone comment on this?
>> >
>> >     Regards,
>> >
>> >     Paul
>> >
>> >     On 4-10-2015 9:45, Paul Bongers wrote:
>> >     > Hi list,
>> >     >
>> >     > I'm trying to set up a WATO plugin to configure parameters for a
>> >     custom
>> >     > agent based check. Thus far I have an option to create custom
>> >     levels via
>> >     > Hosts & Service Parameters -> Parameters for discovered services.
>> >     >
>> >     > When I go to the service and click the icon 'View and edit
>> parameters
>> >     > for this service' it says "Rule 1 in Main directory", but the
>> >     parameter
>> >     > values don't match the ones I specified in the rule.
>> >     >
>> >     > How will I be able to get this to work?
>> >     >
>> >     > Regards,
>> >     >
>> >     > Paul
>> >     > _______________________________________________
>> >     > checkmk-en mailing list
>> >     > checkmk-en at lists.mathias-kettner.de
>> >     <mailto:checkmk-en at lists.mathias-kettner.de>
>> >     > http://lists.mathias-kettner.de/mailman/listinfo/checkmk-en
>> >     >
>> >     > Well meet in Munich for the 2nd Check_MK Conference!
>> >     > Book your place now and be part of it.
>> >     > October 18th-20th, 2015
>> >     > http://mathias-kettner.com/conference
>> >     >
>> >
>> >     _______________________________________________
>> >     checkmk-en mailing list
>> >     checkmk-en at lists.mathias-kettner.de
>> >     <mailto:checkmk-en at lists.mathias-kettner.de>
>> >     http://lists.mathias-kettner.de/mailman/listinfo/checkmk-en
>> >
>> >     Well meet in Munich for the 2nd Check_MK Conference!
>> >     Book your place now and be part of it.
>> >     October 18th-20th, 2015
>> >     http://mathias-kettner.com/conference
>> >
>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mathias-kettner.de/pipermail/checkmk-en/attachments/20151009/9d13baa6/attachment.html>


More information about the checkmk-en mailing list