[Check_mk (english)] Replication between sites broken after upgrade from 1.2.6p16 to 1.2.8p5

Marcel Schulte schulte.marcel at gmail.com
Thu Jul 21 16:55:29 CEST 2016


Hi,

AFAIK before 1.2.8 you were allowed to have site IDs (in distributed setup)
to be different to the "real" sitename. For security and stability reasons
this has been removed in 1.2.8 and your configured site ID must be the name
of the site.

Just my 2ct.

Marcel

Mathieu Levi <mlevi at collective.com> schrieb am Do., 21. Juli 2016 um
16:37 Uhr:

> I ran into a very similar problem after going from 1.2.6p16 to 1.2.8p4
> and had to roll back, and posted about it in June.  No one has replied
> with a solution, I think because (and I am only guessing here since
> the intention isn't clear) this is the result of the developers
> intentionally putting in logic in the WATO/replication code to prevent
> duplicate sites.
>
> https://www.mail-archive.com/checkmk-en@lists.mathias-kettner.de/msg18594.html
>    This happened with OMD+CMK Raw.
>
> I would be grateful for a solution as well.
>
> Matt
>
> "Date: Thu, 21 Jul 2016 11:18:32 +0200
> From: Recuncho Smith
> To: Thomas Mashos
> Cc: "checkmk-en at lists.mathias-kettner.de"
>         <checkmk-en at lists.mathias-kettner.de>
> Subject: Re: [Check_mk (english)] Replication between sites broken
>         after upgrade from 1.2.6p16 to 1.2.8p5
> Message-ID:
>         <
> CALMtAL-EY7XFMtENaMHT_0gf2jsm+spNNma40Zy0ydo+TW8CsA at mail.gmail.com>
> Content-Type: text/plain; charset="utf-8"
>
> Do you use OMD / CRE or standalone check_mk install?
> I have same error with an standalone check_mk install (without OMD / CRE)
> in distributed setup:
>
> "'Internal automation error: Site ID mismatch. Our ID is \'local\', but you
> are saying we are \'stg-002\'.\nTraceback (most recent call last):\n File
> "/usr/share/check_mk/web/htdocs/watolib.py", line 3521, in
> automation_push_snapshot\n (our_id, site_id))\nMKGeneralException: Site ID
> mismatch. Our ID is \'local\', but you are saying we are \'stg-002\'.\n'"
>
> Remote SITE in WATO is "stg-002".
> I do not see where I can change the ID on the remote installation setup.
> I only can resolve this error change code in a python file.
>
> Someone knows how to solve this error?
>
> Javier Rubio.
> "
> _______________________________________________
> checkmk-en mailing list
> checkmk-en at lists.mathias-kettner.de
> http://lists.mathias-kettner.de/mailman/listinfo/checkmk-en
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mathias-kettner.de/pipermail/checkmk-en/attachments/20160721/8a80b78b/attachment.html>


More information about the checkmk-en mailing list