[Check_mk (english)] cannot change levels for esxi datastore

Marius Masalas m.masalas at gmail.com
Wed Feb 6 11:45:20 CET 2019


 Hi,

I'm using vSphere plugin to monitor my ESXi servers. Services are
discovered correctly. I've tried to  create a rule to change default levels
for used datastore space. I've used "Filesystems (used space and growth)"
rule in wato gui, changed warning/critical level to 90/95% for any
datastore. This resulted in following rule in rules.mk:

checkgroup_parameters['filesystem'] = [
  ( {'levels': (90.0, 95.0)}, ['/' + FOLDER_PATH + '/+'], ['esx1'],
ALL_SERVICES, {'description': u'ESXi datastore used space'} ),
] + checkgroup_parameters['filesystem']

Here host 'esx1' is specified explicitly. Still, system uses default levels
(80/90%). I also tried to specify datastore name, but with no result.
Perhaps datastores are evaluated differently from usual filesystems and
different rule has to be used here? Manual says that this check is 100%
compatible with normal filesystem check, so I expected that same rules may
be applied.

Cheers
Marius
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mathias-kettner.de/pipermail/checkmk-en/attachments/20190206/75697c8d/attachment.html>


More information about the checkmk-en mailing list