[Check_mk (english)] weird issue(s) with adding distributed node?

Christian Vo christian.vo at gmail.com
Fri Feb 8 23:11:14 CET 2019


thanks Paul
I can confirm ->  uninstalled that newer ver of check_mk on the slave , and
installed 1.2.6p16
after dealing with some ldaps config issue, my new slave node is
functioning as expected thus far =)

 there are 4 OMD servers  in the distributed monitoring setup (excluding 4
slaves) and each server has about 4 sites configured under omd.
I'm still digging through the previous admin's setup, but it seems some
sites are dedicated monitoring, some sites are just acting as dashboards.
not sure what would be the cleanest/safest way to upgrade these sites.. per
site? per server?


On Fri, Feb 8, 2019 at 10:46 AM Paul Dott <pauldott at gmail.com> wrote:

>
> "is this all related to slave version being too different from the master
> node?"
>
> 99% yes. The Master should not be of lesser version than a slave.
>
> How many sites do you have in your setup? You could downgrade the new
> slave, or upgrade your master.
>
> On Fri, Feb 8, 2019 at 10:07 AM Christian Vo <christian.vo at gmail.com>
> wrote:
>
>> Hi,
>>
>>
>> - our existing Check_MK deployment is running 1.2.6p12
>> - I just created a new slave node (standalone host)  that is running
>> 1.4.0p12
>> - I was able to  add the new slave node to the existing deployment using
>> the instructions found here:
>> https://mathias-kettner.com/cms_distributed_monitoring.html
>> - only difference was that I enabled  using persistent connections
>>
>> - "Apply Changes" seemed to work from the master ,  with last result
>> being "Success" .
>> without adding or assigning any new hosts/services to the slave, I logged
>> into the slave node's website
>> and can see the folders and hosts underneath  ( all pushed from the
>> master)
>>
>> - Issue#1 -- from the slave node's check_mk website, the host entries all
>> show
>> "Unknown site (False)" under the "Monitored on site" column.
>>
>> - if I try to add a new host from the master UI  (host to be monitored on
>> the master) and apply change all seems ok, new test host is pushed to slave
>> - I try to re-assign monitoring of this new host to be monitored by the
>> slave node and push this change, seems to work (no error)
>>
>> - issue #2 - the slave node shows the test host in it's folders and shows
>> it as being monitored by the slave.
>> however it's tactical overview shows 0 hosts and 0 services... Host view
>> -- all hosts also shows nothing
>> - issue#3 --  I can't look up the test host from quicksearch on the
>> master, nothing appears
>>
>> - issue#4 -  I can't do a service discovery on the test host, I get error
>> message "Unable to parse provided data: None"
>>
>> is this all related to slave version being too different from the master
>> node?  I remember reading the version requirement only after I downloaded &
>> installed on the slave =\
>> did I miss anything else? all I want to start is just icmp ping against
>> the test node :)
>>
>> thx
>>
>> Chris
>>
>> _______________________________________________
>> checkmk-en mailing list
>> checkmk-en at lists.mathias-kettner.de
>> Manage your subscription or unsubscribe
>> https://lists.mathias-kettner.de/cgi-bin/mailman/listinfo/checkmk-en
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mathias-kettner.de/pipermail/checkmk-en/attachments/20190208/c768aeb7/attachment-0001.html>


More information about the checkmk-en mailing list