[omd-devel] Problem with OMD start/stop scripts

Mathias Kettner mk at mathias-kettner.de
Wed Dec 15 14:15:22 CET 2010


Hello,

we still seem to have problems with the start/stop scripts
not correctly stopping processes and/or not correctly
detecting if they are running:


-------- Original-Nachricht --------
Betreff: 	Re: [Check_mk (english)] df inventory not working?
Datum: 	Wed, 15 Dec 2010 14:05:30 +0100
Von: 	Rene Draaisma <r.draaisma at junobox.nl>
An: 	Mathias Kettner <mk at mathias-kettner.de>



No, just working fine.
(using omd version 0.45.20101206) = 1.1.9i-1
on ubuntu 10.04 64bit.

BTW, new snapshot builds of OMD give me some other faults:
omd stop testsite
umount: /opt/omd/sites/testsite/tmp: device is busy.
(In some cases useful info about processes that use
the device is found by lsof(8) or fuser(1))
Unmounting temporary filesystem....umount: /opt/omd/sites/testsite/tmp: device is busy.
(In some cases useful info about processes that use
the device is found by lsof(8) or fuser(1))
.umount: /opt/omd/sites/testsite/tmp: device is busy.
(In some cases useful info about processes that use
the device is found by lsof(8) or fuser(1))
.umount: /opt/omd/sites/testsite/tmp: device is busy.
(In some cases useful info about processes that use
the device is found by lsof(8) or fuser(1))
.umount: /opt/omd/sites/testsite/tmp: device is busy.
(In some cases useful info about processes that use
the device is found by lsof(8) or fuser(1))
.umount: /opt/omd/sites/testsite/tmp: device is busy.
(In some cases useful info about processes that use
the device is found by lsof(8) or fuser(1))
.umount: /opt/omd/sites/testsite/tmp: device is busy.
(In some cases useful info about processes that use
the device is found by lsof(8) or fuser(1))
.umount: /opt/omd/sites/testsite/tmp: device is busy.
(In some cases useful info about processes that use
the device is found by lsof(8) or fuser(1))
.umount: /opt/omd/sites/testsite/tmp: device is busy.
(In some cases useful info about processes that use
the device is found by lsof(8) or fuser(1))
.umount: /opt/omd/sites/testsite/tmp: device is busy.
(In some cases useful info about processes that use
the device is found by lsof(8) or fuser(1))
.ERROR: Cannot unmount tmp filesystem.

I need to reboot system first. Then quickly stop omd. Do the omd update of the testsite.
Then
# omd start testsite

I get this error:

omd start testsite
Doing 'start' on site testsite:
Creating temporary filesystem...OK
*Starting dedicated Apache for site testsite... (98)Address already in use: make_sock: could not bind to address
127.0.0.1:5000*
no listening sockets available, shutting down
Unable to open logs
OK.
Starting rrdcached...OK
Starting npcd: done.
Starting nagios... OK.

Apache is not running and will also not start manually. To get it working again, I need to downgrade the omd site back
to version of 6th december.

Is it possible to use the installation packages on http://mathias-kettner.de/check_mk_download.html to update OMD
check_mk version?

Regards,
Rene Draaisma





From: Mathias Kettner <mk at mathias-kettner.de>
To: checkmk-en at lists.mathias-kettner.de
Date: 15/12/2010 12:30
Subject: [Check_mk (english)] df inventory not working?
Sent by: checkmk-en-bounces at lists.mathias-kettner.de
------------------------------------------------------------------------------------------------------------------------



Hi all,

has anybody else of you - using 1.1.9i? - experianced the problem that
the inventory does not find any 'df' services anymore?

Mathias


-- 
__ __ _ __
Mathias Kettner | \/ | |/ / M A T H I A S K E T T N E R
Preysingstr. 74 | |\/| | ' /
81667 München | | | | . \ Linux Beratung & Schulung
089 / 18 90 42 10 |_| |_|_|\_\ http://mathias-kettner.de <http://mathias-kettner.de/>
_______________________________________________
checkmk-en mailing list
checkmk-en at lists.mathias-kettner.de
http://lists.mathias-kettner.de/mailman/listinfo/checkmk-en




More information about the omd-devel mailing list