[omd-users] Legacy checks problem (check_snmp) "No OIDs specified"

Aled Jones d.aled.jones at gmail.com
Thu May 12 15:43:06 CEST 2011


Hello,
Does anyone know what the problem could be here? Im trying to add an snmp
check using check_snmp through check_mk via legacy checks, but I get a
Service State of Unknown and the plugin output is 'No OIDs specified'

Here are my configuration details:

extra_nagios_conf += r"""
define command {
    command_name    check-smtp
    command_line    $USER1$/check_smtp -H $HOSTADDRESS$ -C $ARG1$ -P $ARG2$
-o $ARG3$
}
"""

legacy_checks += [
  ( ( "check_snmp!snmppass!2c!acsPortQueueSize.1", "ACS Queue Size Port 1",
True), [ "rfh" ], ALL_HOSTS ),
]


If I run this from the command line like this...

lib/nagios/plugins/check_snmp -H hostname -C snmppass -o acsPortQueueSize.1

I get the correct response

SNMP OK - 74336


Ive also tried adding this check via a nagios cfg file, but get the same
result. I have been able to do this on a non OMD check_mk installation, so I
think its specific to OMD or perhaps the way its working with the version of
linux?

The OS is Centos 5.6
OMD - Open Monitoring Distribution Version 0.47.20110331


Thanks
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mathias-kettner.de/pipermail/omd-users/attachments/20110512/a11eb7bc/attachment.htm>


More information about the omd-users mailing list