[omd-users] Errors with Install from repo on Scientific Linux 6.4

Ted Fines tfines at digitalriver.com
Wed Jul 17 16:49:34 CEST 2013


For posterity's sake, I have it working on Scientific Linux 6.4 on x86_64.  It looks like the same adjustments need to be made for SL6.4 as for RHEL6.4 or CentOS 6.4.  The issue arises because of 6.4 doesn't want any symbolic links in path names in /etc/fstab.  I do have one change suggestion for the omd devs also.

Here's what I did (two things):

ONE
Read http://blog.christian-stankowic.de/?p=5312&lang=en
He outlines the problem and fix, just for OMD 0.56.
Do this right after installing OMD and before creating any sites.
For OMD 1.00, the change to be made is the same as he outlines, but it is at line 794:
Old line starts with: "file("/etc/fstab", "a+").write("tmpfs  %s tmpfs"
New line starts with: "file("/etc/fstab", "a+").write("tmpfs  /opt%s tmpfs"

TWO
"omd start <Site>" will return a crontab-related error, e.g. "Initializing Crontab...You (TestSite) are not allowed to use this program (/usr/bin/crontab)"
Problem: The OS doesn't allow any users other than root to use crontab.  I don't know when this was changed, but that's how it is now.
Fix: As root, edit /etc/cron.allow and add the user/site name.  One per line.  Fortunately omd generates the crontab for a site on every start, so just do "omd stop <site>" and "omd start <site>" and it will generate the crontab and start correctly.

I think the OMD devs will need to update the omd "create" script to add the site user to /etc/cron.allow.

If I run into other issues down the road I'll post (or ask) them.

Thanks,
Ted

-----Original Message-----
From: omd-users-bounces at lists.mathias-kettner.de [mailto:omd-users-bounces at lists.mathias-kettner.de] On Behalf Of Ted Fines
Sent: Wednesday, July 17, 2013 8:07 AM
To: omd-users at lists.mathias-kettner.de
Subject: Re: [omd-users] Errors with Install from repo on Scientific Linux 6.4

Yes, I do realize using SL6.4 is going off the reservation.  Good to know others have had luck with OMD on other RHEL clone distros, but I do understand there are differences and YMMV!

-----Original Message-----
From: omd-users-bounces at lists.mathias-kettner.de [mailto:omd-users-bounces at lists.mathias-kettner.de] On Behalf Of Joerg Linge
Sent: Wednesday, July 17, 2013 1:43 AM
Cc: omd-users at lists.mathias-kettner.de
Subject: Re: [omd-users] Errors with Install from repo on Scientific Linux 6.4


Am 17.07.2013 um 08:22 schrieb Jens Kuehnel <omd at jens.kuehnel.org>:

> Hi Ted, Hi Jörg,
> 
>>> I have installed omd-1.00 from the repo onto Scientific Linux 
>>> x86_64. No problems getting dependencies met.
> 
>> There is OMD support for Scientific Linux?
>> IMHO there is no Support for this Linux Distribution See
>> http://git.mathias-kettner.de/git/?p=omd.git;a=tree;f=distros;h=ca462
>> a878017e31d4f1e5dde90b7bfacd922ad03;hb=HEAD
> Scientific Linux and Centos are both RedHat Clones. I also run OMD 
> with Oracle Linux and it works as well.

But this Distribution is not supported and tested by the OMD Team.

Jörg
_______________________________________________
omd-users mailing list
omd-users at lists.mathias-kettner.de
http://lists.mathias-kettner.de/mailman/listinfo/omd-users


More information about the omd-users mailing list