[omd-users] Question with regards to HTTPS

Marcel Schulte schulte.marcel at gmail.com
Mon Jun 24 12:45:22 CEST 2013


Hi Jimmy,

We added this to the end of /etc/httpd/conf.d/ssl.conf (RH6, OMD
running own (Sub-)Apache):

RewriteEngine on
RewriteCond %{HTTPS} off
RewriteCond %{HTTPS_HOST} !^hostname\.domain\.tld [NC]
RewriteRule ^.*$ https://hostname.domain.tld%{REQUEST_URI} [L,R]

...this ensures redirected hostname is always hostname.domain.tld and
http gets https.

HTH,
Marcel




2013/6/24 Jimmy Cross <James.Cross at uea.ac.uk>:
> Hi All,
>
> I am attempting to setup https on my OMD server, re-direction works when I
> got straight to server root:
>
> http:\\myserver.co.uk\
>
> will re-direct to https ok
>
> I achieved this by changing the main apache config file.
>
> However when I attempt to go
>
> http:\myserver.co.uk\site\thruk
>
> It will not re-direct to https.
>
> Could someone please let me know which files I should be looking at in order
> to ensure that everything will be re-directed through https.
>
> Many thanks in advance
>
> Best wishes
> Jimmy
>
> --
> -----------------------------
> Mr  James Cross
> Linux Systems Developer
> University of East Anglia
> Norwich Research Park
> ITCS
> Norwich, Norfolk
> NR4 7TJ
>
> Information Services
>
> _______________________________________________
> omd-users mailing list
> omd-users at lists.mathias-kettner.de
> http://lists.mathias-kettner.de/mailman/listinfo/omd-users


More information about the omd-users mailing list