[omd-users] Question with regards to HTTPS

Jimmy Cross James.Cross at uea.ac.uk
Mon Jun 24 15:11:18 CEST 2013


Hi Marcel,

Many thanks again for your help, I have tried what you suggested and it 
doesn't seem to have made a difference.

I have also tried to edit the site specific file:
etc/apache/conf.d/site.conf

With that I get:
403 Forbidden
You dont have pemission to access /hpc/thruk/startup.html on this server.

Anything that I might be able to try or check?

Best wishes
Jimmy



On 24/06/13 12:08, Marcel Schulte wrote:
> Hi Jimmy,
>
> I'm not on Ubuntu but on Debian at another system so maybe the paths
> are similar...
>
> I'd try to copy /etc/apache2/sites-available/default-ssl to
> /etc/apache2/sites-available/default-ssl-with-rewrite and put the
> modifications at the end of that file. Second step would be to link
> that new file to /etc/apache2/sites-enabled/<some_name_to_choose> and
> restart apache.
>
> Quick and dirty, no warranty this works ;-)
>
> HTH,
> Marcel
>
> 2013/6/24 Jimmy Cross <James.Cross at uea.ac.uk>:
>> Hi Marcel,
>>
>> Many thanks for your prompt reply, sorry I should have said I am running
>> Ubuntu 12.04.
>> Do you know which file I should be looking at adding those directives to on
>> that distro?
>>
>> Best wishes
>> Jimmy
>>
>>
>>
>> On 24/06/13 11:45, Marcel Schulte wrote:
>>> Hi Jimmy,
>>>
>>> We added this to the end of /etc/httpd/conf.d/ssl.conf (RH6, OMD
>>> running own (Sub-)Apache):
>>>
>>> RewriteEngine on
>>> RewriteCond %{HTTPS} off
>>> RewriteCond %{HTTPS_HOST} !^hostname\.domain\.tld [NC]
>>> RewriteRule ^.*$ https://hostname.domain.tld%{REQUEST_URI} [L,R]
>>>
>>> ...this ensures redirected hostname is always hostname.domain.tld and
>>> http gets https.
>>>
>>> HTH,
>>> Marcel
>>>
>>>
>>>
>>>
>>> 2013/6/24 Jimmy Cross <James.Cross at uea.ac.uk>:
>>>> Hi All,
>>>>
>>>> I am attempting to setup https on my OMD server, re-direction works when
>>>> I
>>>> got straight to server root:
>>>>
>>>> http:\\myserver.co.uk\
>>>>
>>>> will re-direct to https ok
>>>>
>>>> I achieved this by changing the main apache config file.
>>>>
>>>> However when I attempt to go
>>>>
>>>> http:\myserver.co.uk\site\thruk
>>>>
>>>> It will not re-direct to https.
>>>>
>>>> Could someone please let me know which files I should be looking at in
>>>> order
>>>> to ensure that everything will be re-directed through https.
>>>>
>>>> Many thanks in advance
>>>>
>>>> Best wishes
>>>> Jimmy
>>>>
>>>> --
>>>> -----------------------------
>>>> Mr  James Cross
>>>> Linux Systems Developer
>>>> University of East Anglia
>>>> Norwich Research Park
>>>> ITCS
>>>> Norwich, Norfolk
>>>> NR4 7TJ
>>>>
>>>> Information Services
>>>>
>>>> _______________________________________________
>>>> omd-users mailing list
>>>> omd-users at lists.mathias-kettner.de
>>>> http://lists.mathias-kettner.de/mailman/listinfo/omd-users
>>
>>
>> --
>> -----------------------------
>> Mr  James Cross
>> Linux Systems Developer
>> University of East Anglia
>> Norwich Research Park
>> ITCS
>> Norwich, Norfolk
>> NR4 7TJ
>>
>> Information Services
>>


-- 
-----------------------------
Mr  James Cross
Linux Systems Developer
University of East Anglia
Norwich Research Park
ITCS
Norwich, Norfolk
NR4 7TJ

Information Services



More information about the omd-users mailing list