[omd-users] R: Two OMD - Check_MK questions

Markus Joosten markus.joosten at plumbe.de
Fri May 3 18:41:13 CEST 2013


Andrea,

you need to specify the URI paths to your GUI, as in /sitename/nagios/cgi-bin, /sitename/icinga/cgi-bin, or /sitename/thruk/cgi-bin, just as you would type in your browser.
(actually i'm not sure about the thruk path)

Regards,
Markus


On 03.05.2013, at 18:31, "AC" <ac at itlab.it> wrote:

> Hi,
>    first of all thanks for patience.
> 
> I understand the web ui issue, in OMD I've configured check_mk as default
> web ui for all my sites, but dirs you mention don't exist in my
> installation.
> 
> [root at server] pwd
> /opt/omd/sites/sitename
> [root at server] ls -1
> 
> bin
> etc
> include
> lib
> local
> share
> tmp
> var
> version
> 
> no nagios or icinga dir
> 
> I believe made some mistakes during installation, now I'm in testing and
> there'll be no problem to restart from scratch, but I'd like to understand
> what's going wrong.
> 
> Regards
> 
> Andrea
> 
> 
> 
>> -----Messaggio originale-----
>> Da: omd-users-bounces at lists.mathias-kettner.de [mailto:omd-users-
>> bounces at lists.mathias-kettner.de] Per conto di Joerg Linge
>> Inviato: venerdì 3 maggio 2013 16:58
>> Cc: omd-users at lists.mathias-kettner.de
>> Oggetto: Re: [omd-users] Two OMD - Check_MK questions
>> 
>> 
>> Am 03.05.2013 um 14:32 schrieb "AC" <ac at itlab.it>:
>> 
>>> Hi,
>>> 
>>>> -----Messaggio originale-----
>>>> Da: omd-users-bounces at lists.mathias-kettner.de [mailto:omd-users-
>>>> bounces at lists.mathias-kettner.de] Per conto di Joerg Linge
>>>> Inviato: venerdì 3 maggio 2013 12:10
>>>> Cc: omd-users at lists.mathias-kettner.de
>>>> Oggetto: Re: [omd-users] Two OMD - Check_MK questions
>>>> 
>>>> please adjust etc/pnp4nagios/config.php
>>>> 
>>>> #
>>>> # Link back to Nagios or Thruk ( www.thruk.org ) #
>>>> $conf['nagios_base'] = "/<site>/nagios/cgi-bin";
>>>> 
>>> 
>>> I'm wondering which is the right path to set, cgi-bin dirs are under
>>> /opt/omd/versions/0.56/lib/nagios/ and
>>> /opt/omd/versions/0.56/lib/icinga/
>>> But at the moment I' not able to set nagios_base to point there.
>>> Moreover I'm asking myself if there's something wrong in my setup, it
>>> looks strange to edit config files shipped with OMD, all the rest is
> correct...
>> 
>> OMD contains three GUIs so you have to link pnp4nagios to the GUI _you_
>> want to use.
>> 
>> so change
>> 
>> $conf['nagios_base'] = "/<site>/nagios/cgi-bin";
>> 
>> to
>> 
>> $conf['nagios_base'] = "/<site>/icinga/cgi-bin";
>> 
>> if you prefer Icinga Core & Icinga GUI
>> 
>> Joerg
>> _______________________________________________
>> omd-users mailing list
>> omd-users at lists.mathias-kettner.de
>> http://lists.mathias-kettner.de/mailman/listinfo/omd-users
> 
> 
> _______________________________________________
> omd-users mailing list
> omd-users at lists.mathias-kettner.de
> http://lists.mathias-kettner.de/mailman/listinfo/omd-users



More information about the omd-users mailing list