[omd-users] MSSQL plugin not reporting

Penny Rand penrand at gmail.com
Thu May 9 18:47:24 CEST 2013


OMD .56 on Ubuntu Lucid Server with agent (1.2.2p1) on Windows 2008R2

After updating the agent I am not able to get MSSQL checks on two servers
in the Nagios UI.

If I run check_mk -d SQLINCLDEGV03 on Ubuntu I get all the mssql results in
the console but after running inventory (check_mk -II, check_mk -U and omd
reload) I do not see the MSSQL checks in the UI.

Also if I run "check_mk_agent test" on the Windows server I get this error:
"c:\check_mk\plugins\mssql.vbs(114, 5) Microsoft OLE DB Provider for SQL
Server:
[DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access
denied."

My first thought was that since the SQL server services are running under a
local account it could be permission, I changed the check_mk service
account to the same one that runs SQL server but no JOY!

Windows Firewall is not running and the last agent version did work
correctly (1.2.2b5) showing all checks in the UI.

Any ideas?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mathias-kettner.de/pipermail/omd-users/attachments/20130509/f7b6428d/attachment.html>


More information about the omd-users mailing list