[omd-users] OMD on SLES

Timo Scheller timo.scheller at hiz-saarland.de
Mon Jun 30 12:45:43 CEST 2014


Hi Timotheus,

----- Original Message -----
> From: "B Timotheus" <B.Timotheus at kanaan.org>
> To: omd-users at lists.mathias-kettner.de
> Sent: Monday, June 30, 2014 11:57:49 AM
> Subject: Re: [omd-users] OMD on SLES
> 
> Hello Timo,
> 
> Yes, the proxy and proxy_http modules are in the list.
OK, that is good.

> 
> I am running SLES 11.3.
Also OK.

> 
> I am also running Novell's SMT and a seperate Nagios installation on
> this server. I hope there is not conflict there.
Nope, we use SMT too. But no Nagios-Install on the same server. But that also
shouldn`t be your problem.

> 
> When I run "omd start sitename" it claims to start without errors. But
> when I point Firefox at http://servername/sitename/ it gives me an error
> 404.
> 
> Looking in /var/log/Apache2/error.log I see
> [Mon Jun 30 11:54:27 2014] [error] [client 10.1.100.14] File does not
> exist: /srv/www/htdocs/sitename
> 
> Obviously it should not be looking there, but I do not know how to tell
> Apache where to look.
> 
> Sorry to be so ignorant. When I get a couple of projects finished I
> want to get a book on Apache become a bit more competent.
First, your welcome. ;-) Second, a bit understanding of how apache works
is always a win. ;-)

So just let us look if you have this too:
HOST:/etc/apache2/conf.d # ls -la zzz*
zzz_omd.conf -> /omd/versions/default/share/omd/apache.conf

HOST:/etc/apache2/conf.d # cat zzz_omd.conf
# Include Apache configuration of OMD sites
Include /omd/apache/*.conf

Ans please have a look in 
HOST:/etc/apache2/vhosts.d/ 
if there is anything about virtual hosts.

And also check, if /omd/apache/*.conf are present.


Then go into your site (su - SITENAME) an show your config
omd config show
OMD[SITENAME]:~$ omd config show
APACHE_MODE: own
APACHE_TCP_ADDR: 127.0.0.1
APACHE_TCP_PORT: 5019

This musst be there.



-- 
Best

Timo


More information about the omd-users mailing list