[omd-users] wato problem

Zdeněk Jamečný zdenek.jamecny at skylab.cz
Thu Oct 16 11:15:25 CEST 2014


Dear All,
please can you help me solve my problem? We have multiple cores check_mk and one of them is maybe broken.
If I want to scan from central management Wato devices which are on the problematic core I got this error:
Traceback (most recent call last):
File "/omd/sites/core/share/check_mk/web/htdocs/wato.py", line 315, in page_handler
modefunc("content")
File "/omd/sites/core/share/check_mk/web/htdocs/wato.py", line 15168, in  "inventory" : (["hosts"], lambda phase: mode_inventory(phase, False)),  File "/omd/sites/core/share/check_mk/web/htdocs/wato.py", line 2505, in mode_inventory  show_service_table(host, firsttime)  File "/omd/sites/core/share/check_mk/web/htdocs/wato.py", line 2528, in show_service_table
table.sort()
AttributeError: 'str' object has no attribute 'sort'
When I try to test it with diagnose button I get this:

Exception: Traceback (most recent call last):
File "/omd/sites/core/share/check_mk/web/htdocs/wato.py", line 2416, in ajax_diag_host  html.write("%s %s" % (result[0], html.attrencode(result[1])))
IndexError: string index out of range
I tried to reinstall core, but the problem is still the same :(
When I try to scan devices from wato which is running on this core (not central)  everithing is OK.
When I try to scan devices in another cores from central wato everithing is OK too ..
I would be most grateful if you  send me any hints.
Best Regards
Zdenek
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mathias-kettner.de/pipermail/omd-users/attachments/20141016/35810313/attachment-0001.html>


More information about the omd-users mailing list