[omd-users] omd update fails

Sven Nierlein sven at nierlein.de
Mon Sep 15 14:41:46 CEST 2014


Hi,

i wrote a small guide some time ago:
http://labs.consol.de/lang/de/blog/nagios/debian-ubuntu-dist-upgrade-keeping-omd/

Cheers,
 Sven


On 15.09.2014 14:32, Hans Lambermont wrote:
> Hi OMD list,
>
> Upgrading an ubuntu server box to 14.04 that had omd-1.10 on it gives
> some trouble :
>
> First the /var/lib/dpkg/info/omd-1.10.prerm script broke the ubuntu
> do-release-upgrade process as omd refused to be removed while sites are
> still 'in use'. From the deb prerm script :
>
>     32                echo "Site $site is still using this version!" >&2
>     33                exit 1
>
> I have commented-out line 33 so that do-release-upgrade could continue.
>
> Next the upgrade to omd-1.20 (because there is no omd-1.10 for ubuntu
> server 14.04 and reinstall of omd-1.10 breaks because Dependency
> libboost-program-options1.46.1 is not satisfiable. 14.04 has
> libboost-program-options1.54.0). Download from omdistro.org and install:
> gdebi omd-1.20.trusty.amd64.deb . So far so good.
>
> Next upgrade the configs from 1.10 to 1.20 :
>
> ~/ omd sites
> SITE             VERSION          COMMENTS
> foo              1.10
> bar              1.10
>
> ~/ omd update foo
> Traceback (most recent call last):
>   File "/usr/bin/omd", line 3308, in <module>
>     command_function(args, command_options)
>   File "/usr/bin/omd", line 2746, in main_update
>     unmount_tmpfs(g_sitename)
>   File "/usr/bin/omd", line 758, in unmount_tmpfs
>     config_load_hooks()
>   File "/usr/bin/omd", line 1753, in config_load_hooks
>     for hookname in os.listdir(hook_dir):
> OSError: [Errno 2] No such file or directory: '/omd/sites/foo/lib/omd/hooks'
> ~/ $?=1
>
> Any suggestions on how to proceed ?
>
> -- Hans



More information about the omd-users mailing list