[omd-users] Compiling from source

John Zimmerman john.zimm at gmail.com
Mon Apr 27 04:34:04 CEST 2015


I attempted to compile from source a couple of days ago on CentOS 6 and was
able to compile and build and RPM.  However after install there were some
apache issues and omd complained.

I git pull'd today and started over and everything worked fine.  There's
been a bit of activity in the master branch recently and some things look
like they are getting fixed.

Still having issues after pulling the latest commits?

On Fri, Apr 24, 2015 at 6:09 AM, Stephen Berg (Contractor) <
stephen.berg.ctr at nrlssc.navy.mil> wrote:

> That works nicely for the "make" step. But I get the same error when I run
> "make rpm".
>
>
> On 04/23/2015 08:48 PM, Mirza Dedic wrote:
>
>> You can edit the omd\Makefile and take out the check_mysql_health plugin
>> from the list and then you can run "make" without issues.
>>
>> Perhaps something with the new 2.1.9.2 version of check_mysql_health not
>> playing nice... anyway, going to compile that later manually but the above
>> workaround seems to work.
>>
>> Could also try reverting
>> https://github.com/ConSol/omd/commit/391faffc6e78b802d1b9f773ffe5914fd1adfede
>> to see if make runs OK with 2.1.9.1...
>>
>> Time to play.. :) thank you team omd! :)e
>>
>> -----Original Message-----
>> From: omd-users-bounces at lists.mathias-kettner.de [mailto:
>> omd-users-bounces at lists.mathias-kettner.de] On Behalf Of Mirza Dedic
>> Sent: April/23/2015 6:16 PM
>> To: Stephen Berg (Contractor); omd-users at lists.mathias-kettner.de
>> Subject: Re: [omd-users] Compiling from source
>>
>> I mean Ubuntu Server 14.04.2 LTS.
>>
>> -----Original Message-----
>> From: omd-users-bounces at lists.mathias-kettner.de [mailto:
>> omd-users-bounces at lists.mathias-kettner.de] On Behalf Of Mirza Dedic
>> Sent: April/23/2015 6:13 PM
>> To: Stephen Berg (Contractor); omd-users at lists.mathias-kettner.de
>> Subject: Re: [omd-users] Compiling from source
>>
>> I tried to compile OMD from source as well but no luck, got the same
>> error as you with a clean Ubuntu 10.04.2 LTS virtual machine..
>>
>> config.status: creating t/Makefile
>> ./configure: line 4149: syntax error near unexpected token `with,perl'
>> ./configure: line 4149: `ACX_FEATURE(with,perl)'
>> make[1]: *** [build] Error 2
>> make[1]: Leaving directory `/downloads/omd/packages/check_mysql_health'
>> make: *** [build] Error 2
>>
>> Can't seem to get passed this..
>>
>> -----Original Message-----
>> From: omd-users-bounces at lists.mathias-kettner.de [mailto:
>> omd-users-bounces at lists.mathias-kettner.de] On Behalf Of Stephen Berg
>> (Contractor)
>> Sent: April/23/2015 7:48 AM
>> To: omd-users at lists.mathias-kettner.de
>> Subject: [omd-users] Compiling from source
>>
>> Tried to compile from source using
>>
>> #> git clone http://git.mathias-kettner.de/omd.git/
>> #> cd omd
>> #> ./configure
>> #> make
>> #> make rpm
>>
>> When I ran the "make" it ended with a couple of errors:
>> config.status: creating t/Makefile
>> ./configure: line 4149: syntax error near unexpected token `with,perl'
>> ./configure: line 4149: `ACX_FEATURE(with,perl)'
>> make[1]: *** [build] Error 2
>> make[1]: Leaving directory `/root/omd/omd/packages/check_mysql_health'
>> make: *** [build] Error 2
>>
>> Tried the "make rpm" just for laughs and got more errors:
>>
>> config.status: creating t/Makefile
>> ./configure: line 4149: syntax error near unexpected token `with,perl'
>> ./configure: line 4149: `ACX_FEATURE(with,perl)'
>> make[2]: *** [build] Error 2
>> make[2]: Leaving directory
>> `/root/omd/omd/rpm.topdir/BUILD/omd-1.20/packages/check_mysql_health'
>> make[1]: *** [build] Error 2
>> make[1]: Leaving directory `/root/omd/omd/rpm.topdir/BUILD/omd-1.20'
>> error: Bad exit status from /var/tmp/rpm-tmp.2cnjBH (%build)
>>
>>
>> RPM build errors:
>>       Bad exit status from /var/tmp/rpm-tmp.2cnjBH (%build)
>> make: *** [rpm] Error 1
>>
>> This is on a SciLinux 7.1 system, I changed /etc/redhat-release so the
>> system thinks it's CentOS 7.0 to get the ./configure to run.  Is there
>> an easy fix for this?
>>
>>
>
> --
> Stephen Berg
> Systems Administrator
> NRL Code: 7320
> Office: 228-688-5738
> stephen.berg.ctr at nrlssc.navy.mil
>
> _______________________________________________
> omd-users mailing list
> omd-users at lists.mathias-kettner.de
> http://lists.mathias-kettner.de/mailman/listinfo/omd-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mathias-kettner.de/pipermail/omd-users/attachments/20150426/2bad18f7/attachment-0001.html>


More information about the omd-users mailing list