[omd-users] Ubuntu 14.04 Updates try to remove OMD1.10

penny.rand at thomsonreuters.com penny.rand at thomsonreuters.com
Fri Aug 14 01:25:20 CEST 2015


Catch 22?
I tried to upgrade OMD1.10 to OMD1.20 but get the error:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done
Building data structures... Done
This package is uninstallable
Cannot install 'apache2-mpm-prefork'

Tried to run apt-get update on 14.04 and get the error:
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 perl : Depends: perl-base (= 5.18.2-2ubuntu1) but 5.14.2-6ubuntu2.4 is installed
        Depends: perl-modules (>= 5.18.2-2ubuntu1) but 5.14.2-6ubuntu2.4 is installed
E: Unmet dependencies. Try using -f.

I tried -f and get this:
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 517109 files and directories currently installed.)
Removing omd-1.10 ...
Site INCLDEGV is still using this version!
dpkg: error processing omd-1.10 (--remove):
 subprocess installed pre-removal script returned error exit status 1
Errors were encountered while processing:
 omd-1.10
E: Sub-process /usr/bin/dpkg returned an error code (1)

So I can't upgrade OMD until I upgrade Trusty but Trusty won't upgrade!
Do I need to uninstall OMD1.10? 
Thank you for help.
Penny


More information about the omd-users mailing list