[omd-users] Upgrade from omd 1.20 on squeeze to 1.30 on wheezy or jessie

Christian Haase c.haase at ifu.com
Tue Nov 3 15:11:07 CET 2015


Hi,

while upgrading my squeeze monitoring server I hit the problem that most
of the omd versions are gone from the debian repository. The last
squeeze version is 1.20, but the first wheezy/jessie version is 1.30.
The squeeze 1.20 package is incompatible with wheezy and jessie.

This brings me in a situation where I cannot install 1.20 and 1.30 at
the same time to do "omd update site".

I document my way of upgrading if somebody encounters the same problem.
For this the site should be shut down and disabled and backed up (as the
generated package is untested). I upgraded to wheezy, did the omd
upgrade and then upgraded to jessie.

mkdir upgrade
cd upgrade

# check architecture
wget
https://labs.consol.de/repo/stable/debian/dists/squeeze/main/binary-amd64/omd-1.20.squeeze.amd64.deb

dpkg-deb -x omd-1.20.squeeze.amd64.deb my-omd-1.20
dpkg-deb -e omd-1.20.squeeze.amd64.deb my-omd-1.20/DEBIAN
cp /tmp/control my-omd-1.20/DEBIAN/control (see attachment)
dpkg-deb -b my-omd-1.20

dpkg -i <generated .deb>

omd update site
apt-get remove omd-1.20 # As mentioned, this is an untested package

HTH,
Christian


-- 
ifu Hamburg - material flows and software
"We enable sustainable production."

ifu Hamburg GmbH
Max-Brauer-Allee 50 - 22765 Hamburg - Germany
fon: +49 40 480009-0 - fax: +49 40 480009-22 - email: info at ifu.com

Managing Director: Jan Hedemann - Commercial Register: Hamburg, HRB 52629
www.ifu.com - www.umberto.de - www.e-sankey.com
-------------- next part --------------
Package: omd-1.20
Version: 0.squeeze
Architecture: amd64
Maintainer: OMD-Team <debian at omdistro.org>
Installed-Size: 360044
Depends: debconf (>= 0.5) | debconf-2.0, time, traceroute, curl, dialog, dnsutils, fping, graphviz, libapache2-mod-fcgid, libapache2-mod-proxy-html, libboost-program-options1.42.0, libdbi0, libevent-1.4-2, libgd2-xpm, libltdl7, libnet-snmp-perl, libpango1.0-0, libperl5.10 | libperl5.14 | libperl5.20, libreadline6, libsnmp-perl, libuuid1, libpython2.6, mysql-server, patch, php5, php5-cgi, php5-cli, php5-gd, php5-mcrypt, php5-sqlite, php-pear, rsync, snmp, unzip, xinetd, xvfb, python-ldap, libradiusclient-ng2
Section: admin
Priority: optional
Homepage: http://www.omdistro.org
Description: Open Source Monitoring Distribution, containing Nagios,
 the Nagios plugins, Check_MK, Livestatus, Multisite,
 PNP4Nagios, NagVis, and other addons. Please visit
 http://omdistro.org/.


More information about the omd-users mailing list