[omd-users] Upgrade problem

Andreas Döhler andreas.doehler at gmail.com
Sat May 30 17:43:27 CEST 2020


Hi Dave,

it sounds like a problem that every of your sites don't know witch hosts
belong to another.
How was your upgrade path?
All servers together and then push one time the config from the central
system to the slaves?

On one of your sites you can do a "cmk -D hostname".
In the Tags section you find a tag [site:yoursitename] is this tag the same
name as inside the file ~/etc/check_mk/conf.d/distributed_wato.mk
There you should have two entries like this.

On the master

distributed_wato_site = 'site1'
is_wato_slave_site = False

On the slave

distributed_wato_site = 'site2'
is_wato_slave_site = True

If this is not the same as shown in the hosttags section it ca lead to such
a problem like you see.

Best regards
Andreas

PS: for Questions for Check_MK it is better to use now the new forum under
- https://forum.checkmk.com/

Am Fr., 29. Mai 2020 um 19:48 Uhr schrieb Dave Ford via omd-users <
omd-users at lists.mathias-kettner.de>:

> I've just upgraded our estate from version 1.5.0p23.cre to 1.6.0p12.cre
> and while it mostly has gone fine. we've noted one potentially
> catasphoric problem.
>
> We have three servers, server1 - monting general purpose machines,
> server2 - monitoring 1000 hosts but only with a ping no check_mk agents
> and server3 monitoring various appliances via SNMP.
>
> This all worked fine - hosts were assigned to a site via their
> container folder in WATO.
>
> However, following the upgrade althrough the WATO interface looks
> right, the search system is reporting three of everything - every host
> is visable from every server.
>
> E.g. when we look at the serives on a server we get a urL ocntaining:
>
> https://
> <mainserver>/...check_mk/view.py?host=testhost&site=WRONGSITEHERE&view_name=host...
>
> Where WRONGSITEHERE can be server1, server2 or server3 despite the
> testhost being listed as one.
>
> Similarly if I list 'All Hosts' each host is listed under each site.
> The good news is that it doesn't appear that all three check_mk servers
> are performing all of the checks for all of the hosts.
>
>
> This is proving confusing and problematic as only servder1 has an
> Oracle client installed, so for two of the three search results active
> SQL checks appear to be failing.
>
> Obviously, I could install the oracle client on all three servers - but
> this doesn't fix the issue  Is there a way to revert to the behaveour
> we saw previously - where each host is only listed for the site it's a
> member off?
>
> Have I missed a step during the upgrade process? I did this following
> the instrctions and noticed no errors or warnings.
>
> Thanks
> Dave
> _______________________________________________
> omd-users mailing list
> omd-users at lists.mathias-kettner.de
> Manage your subscription or unsubscribe
> https://lists.mathias-kettner.de/cgi-bin/mailman/listinfo/omd-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mathias-kettner.de/pipermail/omd-users/attachments/20200530/8b2384fd/attachment.html>


More information about the omd-users mailing list