<div dir="ltr">xinetd is running and the following is my /opt/omd/sites/SlaveRPLS/etc/mk-livestatus/xinetd.conf<br><div><br></div><div><div>service livestatus</div><div>{</div><div>        type            = UNLISTED</div><div>        socket_type     = stream</div><div>        protocol        = tcp</div><div>        wait            = no</div><div><br></div><div>        # limit to 100 connections per second. Disable 3 secs if above.</div><div>        cps             = 100 3</div><div><br></div><div>        # set the number of maximum allowed parallel instances of unixcat.</div><div>        # Please make sure that this values is at least as high as</div><div>        # the number of threads defined with num_client_threads in</div><div>        # etc/mk-livestatus/nagios.cfg</div><div>        instances       = 500</div><div><br></div><div>        # limit the maximum number of simultaneous connections from</div><div>        # one source IP address</div><div>        per_source      = 250</div><div><br></div><div>        # Disable TCP delay, makes connection more responsive</div><div>        flags           = NODELAY</div><div># configure the IP address(es) of your Nagios server here:</div><div>#       only_from       = 127.0.0.1 10.0.20.1 10.0.20.2</div><div><br></div><div># ----------------------------------------------------------</div><div># These parameters are handled and affected by OMD</div><div># Do not change anything beyond this point.</div><div><br></div><div># Disabling is done via omd config set LIVESTATUS_TCP [on/off].</div><div># Do not change this:</div><div>        disable         = no</div><div><br></div><div># TCP port number. Can be configure via LIVESTATUS_TCP_PORT</div><div>        port            = 6557</div><div><br></div><div># Paths and users. Manual changes here will break some omd</div><div># commands such as 'cp', 'mv' and 'update'. Do not toutch!</div><div>        user            = SlaveRPLS</div><div>        server          = /omd/sites/SlaveRPLS/bin/unixcat</div><div>        server_args     = /omd/sites/SlaveRPLS/tmp/run/live</div><div># ----------------------------------------------------------</div><div>}</div></div><div><br></div><div>There is no port listed so should I add?</div><div><br></div><div>Thanks.</div></div><div class="gmail_extra"><br><div class="gmail_quote">On 7 May 2015 at 14:48, May,Allen <span dir="ltr"><<a href="mailto:AMAY@vha.com" target="_blank">AMAY@vha.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">





<div lang="EN-US" link="blue" vlink="purple">
<div>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">Is your livestatus set and xinetd restarted?  Disable = yes  may be the default…can’t remember.<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d"><u></u> <u></u></span></p>
<p class="MsoNormal"># cat /etc/xinetd.d/livestatus<u></u><u></u></p>
<p class="MsoNormal">service livestatus<u></u><u></u></p>
<p class="MsoNormal">{<u></u><u></u></p>
<p class="MsoNormal">        type            = UNLISTED<u></u><u></u></p>
<p class="MsoNormal">        port            = 6557<u></u><u></u></p>
<p class="MsoNormal">        socket_type     = stream<u></u><u></u></p>
<p class="MsoNormal">        protocol        = tcp<u></u><u></u></p>
<p class="MsoNormal">        wait            = no<u></u><u></u></p>
<p class="MsoNormal"># limit to 100 connections per second. Disable 3 secs if above.<u></u><u></u></p>
<p class="MsoNormal">        cps             = 100 3<u></u><u></u></p>
<p class="MsoNormal"># set the number of maximum allowed parallel instances of unixcat.<u></u><u></u></p>
<p class="MsoNormal"># Please make sure that this values is at least as high as<u></u><u></u></p>
<p class="MsoNormal"># the number of threads defined with num_client_threads in<u></u><u></u></p>
<p class="MsoNormal"># etc/mk-livestatus/nagios.cfg<u></u><u></u></p>
<p class="MsoNormal">        instances       = 500<u></u><u></u></p>
<p class="MsoNormal"># limit the maximum number of simultaneous connections from<u></u><u></u></p>
<p class="MsoNormal"># one source IP address<u></u><u></u></p>
<p class="MsoNormal">        per_source      = 250<u></u><u></u></p>
<p class="MsoNormal"># Disable TCP delay, makes connection more responsive<u></u><u></u></p>
<p class="MsoNormal">        flags           = NODELAY<u></u><u></u></p>
<p class="MsoNormal">        user            = lab<u></u><u></u></p>
<p class="MsoNormal">        server          = /omd/sites/lab/bin/unixcat<u></u><u></u></p>
<p class="MsoNormal">        server_args     = /omd/sites/lab/tmp/run/live<u></u><u></u></p>
<p class="MsoNormal"># configure the IP address(es) of your Nagios server here:<u></u><u></u></p>
<p class="MsoNormal">#       only_from       = 127.0.0.1 10.0.20.1 10.0.20.2<u></u><u></u></p>
<p class="MsoNormal">        disable         = no<u></u><u></u></p>
<p class="MsoNormal">}<span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d"><u></u><u></u></span></p>
<p class="MsoNormal"><b><span style="font-size:10.0pt;font-family:"Tahoma","sans-serif"">From:</span></b><span style="font-size:10.0pt;font-family:"Tahoma","sans-serif""> <a href="mailto:omd-users-bounces@lists.mathias-kettner.de" target="_blank">omd-users-bounces@lists.mathias-kettner.de</a> [mailto:<a href="mailto:omd-users-bounces@lists.mathias-kettner.de" target="_blank">omd-users-bounces@lists.mathias-kettner.de</a>]
<b>On Behalf Of </b>Peter Shankland<br>
<b>Sent:</b> Thursday, May 07, 2015 8:42 AM<br>
<b>To:</b> <a href="mailto:omd-users@lists.mathias-kettner.de" target="_blank">omd-users@lists.mathias-kettner.de</a><br>
<b>Subject:</b> [omd-users] Fresh Install of OMD 1.20 on CentOS 6.6 64Bit - Livestatus Not Running<u></u><u></u></span></p>
<p class="MsoNormal"><u></u> <u></u></p>
<div>
<p class="MsoNormal">Hi all,<u></u><u></u></p>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<p class="MsoNormal">As the subject suggests, I have created two new CentOS 6.6 64Bit servers and installed OMD 1.20 on them ready to use one as a master and the other as a slave. The installations appear to have gone fine and I have managed to configure the
 distributed monitoring and the config has gone from the master to the slave.<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<p class="MsoNormal">The issue I have is with Livestatus as nothing is getting reported back to the master. Also, when I run netstat -ln|grep 6557 on both machines, nothing is reporting.<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<p class="MsoNormal">My nagios.log shows the following:<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<div>
<p class="MsoNormal">[1431005132] livestatus: Finished initialization. Further log messages go to /omd/sites/SlaveRPLS/var/nagios/livestatus.log<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">[1431005132] Event broker module '/omd/sites/SlaveRPLS/lib/mk-livestatus/livestatus.o' initialized successfully.<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">[1431005132] Finished daemonizing... (New PID=1444)<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">[1431005132] TIMEPERIOD TRANSITION: 24X7;-1;1<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">[1431005132] TIMEPERIOD TRANSITION: 24x7;-1;1<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">[1431005132] TIMEPERIOD TRANSITION: none;-1;0<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">[1431005132] TIMEPERIOD TRANSITION: thruk_24x7;-1;1<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">[1431005132] logging initial states<u></u><u></u></p>
</div>
</div>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<p class="MsoNormal">and my livestatus.log shows this:<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<div>
<p class="MsoNormal">2015-05-07 14:25:15 deinitializing<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">2015-05-07 14:25:15 Waiting for main to terminate...<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">2015-05-07 14:25:17 Waiting for client threads to terminate...<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">2015-05-07 14:25:17 Logfile cache: flushing complete cache.<u></u><u></u></p>
</div>
</div>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<p class="MsoNormal">The above is happening on both machines.<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<p class="MsoNormal">So, I can see that livestatus is not running but not sure how to start debugging the issue from here as first time using it and OMD - any suggestions would be useful.<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<p class="MsoNormal">Thanks.<u></u><u></u></p>
</div>
</div>
</div>

<div><p></p><hr>
---------------------------------------------------------------------------<br>
The information transmitted in this e-mail and in any replies and forwards are for the sole use of the above individual(s) or entities and may contain proprietary, privileged and/or highly confidential information. Any unauthorized dissemination, review, distribution or copying of these communications is strictly prohibited. If this e-mail has been transmitted to you in error, please notify and return the original message to the sender immediately at the above listed address. Thank you for your cooperation.<br>

<p></p></div>
</div>

</blockquote></div><br></div>