<div dir="ltr">You can use it with command line configuration. There the old style <a href="http://main.mk">main.mk</a> file will be edited and with calling "cmk -R" you generate classic Nagios checks and then restart the core.<div>The templates are needed for this check generation.</div><div>If you configure with the GUI then in the background the same commands are issued and the configuration is generated.</div><div><br></div><div>What is also a great help is to configure a host inside WATO and then take a look at the generated .mk files inside /omd/sites/<your-site>/etc/check_mk/conf.d/wato/<a href="http://hosts.mk">hosts.mk</a> and <a href="http://rules.mk">rules.mk</a></div><div>Then it is possible if you prefer a hand made configuration to take theses files as an example how to build your own .mk files and generate the Nagios config with "cmk -R".</div><div><br></div><div>The following link gives a short explanation what are these .mk files are doing - <a href="https://mathias-kettner.de/checkmk_configfiles.html">https://mathias-kettner.de/checkmk_configfiles.html</a></div><div><br></div><div>br</div><div>Andreas</div></div><br><div class="gmail_quote"><div dir="ltr">Zach LaCelle <<a href="mailto:lacelle@roboticresearch.com">lacelle@roboticresearch.com</a>> schrieb am Di., 22. Aug. 2017 um 21:05 Uhr:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
  
    
  
  <div bgcolor="#FFFFFF" text="#000000">
    Hello Andreas,<br>
    <br>
    I'm currently using the Thruk2 UI, and navigating simply to
    <a class="m_2888417909731201258moz-txt-link-freetext">http://</a><your-host>/<your-site>.<br>
    <br>
    If we can't use the check_mk tools with traditional Nagios, why are
    there check_mk templates all over the place?<br>
    <br>
    I will go to the check_mk URL and learn about the WATO tool.  Thank
    you!</div><div bgcolor="#FFFFFF" text="#000000"><br>
    <br>
    -Zach</div><div bgcolor="#FFFFFF" text="#000000"><br>
    <br>
    <div class="m_2888417909731201258moz-cite-prefix">On 08/22/2017 03:03 PM, Andreas Döhler
      wrote:<br>
    </div>
    <blockquote type="cite">
      <div dir="ltr">Hi Zach,
        <div><br>
        </div>
        <div>you cannot define old school Nagios service definitions for
          check_mk.</div>
        <div>What type of webgui do you use? Classic Nagios GUI or
          Check_MK Multisite or Thruk?</div>
        <div>Try the following URL -->
           <a class="m_2888417909731201258moz-txt-link-freetext">http://</a><your-host/<your-site>/check_mk/   login with
          your admin account then you have the possibility to edit the
          check_mk configuration inside WATO (web administration tool).</div>
        <div><br>
        </div>
        <div>br</div>
        <div>Andreas</div>
      </div>
      <br>
      <div class="gmail_quote">
        <div dir="ltr">Zach LaCelle <<a href="mailto:lacelle@roboticresearch.com" target="_blank">lacelle@roboticresearch.com</a>>
          schrieb am Di., 22. Aug. 2017 um 19:21 Uhr:<br>
        </div>
        <blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hello,<br>
          <br>
          I'm trying out OMD as a replacement to custom-configured
          Nagios3, and so<br>
          far I like a lot of the changes.  However, I'm having issues
          getting<br>
          check_mk to run within the framework.  Hopefully this is a
          simple fix.<br>
          <br>
          I've followed the instructions to get a Nagios site running,
          and have<br>
          installed the check_mk_agent package on a test server.  I can
          telnet to<br>
          that server from the OMD server and see the outputs of the<br>
          check_mk_agent process, so it looks like the agent is running
          correctly.<br>
          <br>
          However, when I set up a service inside of Nagios on the OMD
          site, it<br>
          complains about the following:<br>
          (No output on stdout) stderr: python: can't open file<br>
          '/omd/sites/nagios/var/check_mk/precompiled/<machine
          name>': [Errno 2]<br>
          No such file or directory<br>
          <br>
          The service I've set up look as follows:<br>
          define service {<br>
             service_description            check-mk<br>
             host_name                      <machine name><br>
             use                            check_mk_active<br>
             check_command                  check-mk<br>
             contact_groups                 sysadmins<br>
          }<br>
          <br>
          What is the correct way to set up the configuration from the
          OMD<br>
          website, so that it precompiles the plugins to run and runs
          the correct<br>
          binary?<br>
          <br>
          Thank you!<br>
          _______________________________________________<br>
          omd-users mailing list<br>
          <a href="mailto:omd-users@lists.mathias-kettner.de" target="_blank">omd-users@lists.mathias-kettner.de</a><br>
          <a href="http://lists.mathias-kettner.de/mailman/listinfo/omd-users" rel="noreferrer" target="_blank">http://lists.mathias-kettner.de/mailman/listinfo/omd-users</a><br>
        </blockquote>
      </div>
    </blockquote>
    <br>
  </div></blockquote></div>